FiTech EFI Tuning Forum

Please or Register to create posts and topics.

Current Version of Software

I am new to your forum so please excuse me if i am in the wrong topic.

i am working on a new installation of a 70001 ultimate ram system on a stock 99 trans-am ls1 mounted in an air boat and have ran into an issue which prompts a couple of questions.

It fires the prime shot then makes several revolutions of not firing the it tries to fire again but acts and sounds like it is over advanced. While watching the data logging screen I noticed while attempting to start that the spark timing continues to advance the longer you crank. It starts out at 4.5 then jumps to 17 when it fires off of the prime squirt which I expect it to do. But then it continues to advance upon continued cranking. It up to 52 to 60 degrees in about 2 to 3 revolutions.
We are in the process of verifying cmp and ckp sensors and wiring.  We have pulled the fuel pump relay and cranked the engine and do get around 20o rpm which I consider normal but doesn’t rule out a missing pulse occasionally However the engine ran with the oem pcm several months ago using those sensors which leads me to these questions.
Is this a known indication of a particular failure and if so what is required fix.
The software version shown in the hand held is GD-V149 is there a new version?
And lastly what is the trigger pulse voltage the pcm is looking for? I am suspecting a weak  ckp pulse where the fitech pcm doesn’t see it and the pcm did.

Austin DeHaas has reacted to this post.
Austin DeHaas

Go into the dashboard and scroll to Battery line.  If voltage drops below 10.5v while cranking, the injectors are not opening.  Must carry more than 10.5v while cranking

Also, it couldn't hurt to run ECU programmer and then Write Cal to ECU.  This will reflash all the software.  Then go back through to set all your initial setups.


We have done both of the procedures without any change. After reloading the pcm programming the first time and every time since I noticed the “ignition type” “vr coil” or “tach” question was not displayed. As for battery voltage the handheld shows 10.8 while cranking with the fuel relay pulled. According to some information i found on 24x hall effect sensors from GM, they say the reference voltage to the ckp and cmp should not drop below 11.5 or the sensor output may become unstable. We are seeing the injectors firing, but if the ckp signal is weak or missing pulses they could be firing out of sync I wouldn’t know it. I don’t have an o-scope to validate that. That is why I was looking for the required pulse voltage input for the pcm. In my years at my previous job i dealt with alot of hall effect sensors .I have found the for most part if they trigger they usually don’t miss pulses unless the gap is to wide, but their pulse output voltage can decline with age particularly in high heat environments(+160f) such as on an engine.
My plan going forward is to verify the ckp is pulsing by pulling the spark plugs and baring the engine over slowly with the sensor powered up I should see output pulses.  And checking sensor reference and output voltages at the sensor while cranking. But I will not get back on it until this Sunday at the earliest.

Update on we have found.
The ckp sensor pluses were good at 12.2 dc volts. However the cmp sensor pluses were not good, varying from 7 to just under 8 dc volts. The sensors were tested in place by removing the spark plugs, probing the back of the sensors’ plug with a volt meter set to dc with the plus probe on the sensor signal pin and the negative probe on the 0 reference pin and barring the engine over slowly by hand. Also found sensor wiring going back to the pcm tie rapped to the battery cable and the power for the pcm on the main post for the starter.  We have ordered replacement sensors for both sensors as they are the original 25 year old ones. And are moving the injection wiring so that it is at least several inches away from the battery cable to the starter and moving the pcm power to the battery post. We’ll see how that works.


We have replaced the cmp and ckp sensors, moved main wiring harness a couple of inches away from the battery cable and moved the ecm power from the starter post to the battery post. The ckp pulse stayed the same as I expected, the cmp pulse camp up a volt to 8.5-8.9 dc volts, and the voltage to ecm while cranking with the fuel pump running was 10.9 at its lowest voltage.

The engine is now firing for about a sec almost instantly when hitting the start button from the prime shot. But it still will not remain running. The fuel pressure droops to about 55 psi then goes back up to 59 psi when the fuel pump kicks back in and we are seeing injectors and coils still firing with test light after it quits running still cranking. In monitoring the logging screen of the handheld, we see the ignition continually advancing with the it ramping to 52 to 60 degrees advanced after cranking for 3 seconds. The other things we see on the logging screen are the Starting % goes to 100% the Mode goes from starting, to running then stall, we see the RPM go up to 1500 to 1700 rpm before falling back to about 200 rpm cranking speed and doesn't try to fire even a little bit, the injector pulse width starts to increase slightly then quits increasing when the stall mode appears. The fault code of 39(cam unsync) that was showing up intermittently before we changed the cmp is gone. However, there is a soft fault of 136 (Wideband B heater) that shows up around the 4 to 5 sec mark if we try cranking that long which is possible as there is only 1 O2 sensor and the ecm is looking for 2, but that shouldn't prevent it from running.

We have loaded all of the different setups in the handheld into ecm. Verified the setup, made sure timing and AFR tables were set up with 10 degrees initial timing and 26 total timing, AFR 13.2 for starting, 14.3 for cruise and 12.8 for power.  We have tried increasing and decreasing the IAC until it errors (fault 53), tried opening the butterfly a turn or two and wide open, changed starting fuel up and down, changed afterstart fuel up and down. No change in the result it only fires for about a second and the timing continues to advance to 52 to 60 degrees advance in about 3 seconds then holds at 60 degrees if cranking longer.

I suspect there maybe a programming issue and the ecm or handheld may need to be reflashed with different programming. Because I don't think that timing should advance beyond total timing setpoint in any scenario. So, I believe the next step may be to contact FiTech tech support. Unless anyone else has any ideas as I have about worn out what little hair I have left, scratching my head!